#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!(d|b y|toy);([^;\r\n]*);([^;\r\n]*)).*\R"
Local $sString = "" & @CRLF & _
"a;; z" & @CRLF & _
"toy;d;hh " & @CRLF & _
"z;" & @CRLF & _
"d;23" & @CRLF & _
";;io;" & @CRLF & _
"b y;b;12" & @CRLF & _
"" & @CRLF & _
"a;b;bb;;;34" & @CRLF & _
" "
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)