#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?:^|\G).*?([\w_]+\.(?:jpg|wmv))"
Local $sString = "output 1" & @CRLF & _
"" & @CRLF & _
"abc.jpg" & @CRLF & _
"def.jpg" & @CRLF & _
"fgh.jpg" & @CRLF & _
"" & @CRLF & _
"output 2" & @CRLF & _
"" & @CRLF & _
"_01.wmv" & @CRLF & _
"_02.wmv" & @CRLF & _
"_03.wmv"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)