re = /(?:^|\G).*?([\w_]+\.(?:jpg|wmv))/
str = 'output 1
abc.jpg
def.jpg
fgh.jpg
output 2
_01.wmv
_02.wmv
_03.wmv'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result