import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\G).*?([\\w_]+\\.(?:jpg|wmv))";
final String string = "output 1\n\n"
+ "abc.jpg\n"
+ "def.jpg\n"
+ "fgh.jpg\n\n"
+ "output 2\n\n"
+ "_01.wmv\n"
+ "_02.wmv\n"
+ "_03.wmv";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}