using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\G).*?([\w_]+\.(?:jpg|wmv))";
string substitution = @"\1";
string input = @"output 1
abc.jpg
def.jpg
fgh.jpg
output 2
_01.wmv
_02.wmv
_03.wmv";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}