use strict;
my $str = 'output 1
abc.jpg
def.jpg
fgh.jpg
output 2
_01.wmv
_02.wmv
_03.wmv';
my $regex = qr/(?:^|\G).*?([\w_]+\.(?:jpg|wmv))/sp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";