#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^)(?: {4})*+( {1,})"
Local $sString = " Bad Indent (3)" & @CRLF & _
" Good Indent (4)" & @CRLF & _
" Bad Indent (7)" & @CRLF & _
" Good Indent (8)" & @CRLF & _
" Bad Indent (10)" & @CRLF & _
" Good Indent (12)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")