import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^)(?: {4})*+( {1,})";
final String string = " Bad Indent (3)\n"
+ " Good Indent (4)\n"
+ " Bad Indent (7)\n"
+ " Good Indent (8)\n"
+ " Bad Indent (10)\n"
+ " Good Indent (12)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}