re = /(?:^)(?: {4})*+( {1,})/m
str = ' Bad Indent (3)
Good Indent (4)
Bad Indent (7)
Good Indent (8)
Bad Indent (10)
Good Indent (12)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end