$re = '/(?:^)(?: {4})*+( {1,})/m';
$str = ' Bad Indent (3)
Good Indent (4)
Bad Indent (7)
Good Indent (8)
Bad Indent (10)
Good Indent (12)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);