package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^)(?: {4})*+( {1,})`)
var str = ` Bad Indent (3)
Good Indent (4)
Bad Indent (7)
Good Indent (8)
Bad Indent (10)
Good Indent (12)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}