using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^)(?: {4})*+( {1,})";
string input = @" Bad Indent (3)
Good Indent (4)
Bad Indent (7)
Good Indent (8)
Bad Indent (10)
Good Indent (12)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}