// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^)(?: {4})*+( {1,})").unwrap();
let string = " Bad Indent (3)
Good Indent (4)
Bad Indent (7)
Good Indent (8)
Bad Indent (10)
Good Indent (12)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}