# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/~\\/remove\\/me[^\s]*\\/(?=[^\s]+)/ /gmi;t' <<< "~/remove/me/myexec.pl /some/other/path/exec.pl
/yet/another/path/pipeit.pl | ~/remove/me/subdir/tome.pl
~/remove/me/deeply/nested/exec.pl"