const regex = /~\/remove\/me[^\s]*\/(?=[^\s]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('~\\\/remove\\\/me[^\\s]*\\\/(?=[^\\s]+)', 'gmi')
const str = `~/remove/me/myexec.pl /some/other/path/exec.pl
/yet/another/path/pipeit.pl | ~/remove/me/subdir/tome.pl
~/remove/me/deeply/nested/exec.pl`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);