import re
regex = re.compile(r"~\/remove\/me[^\s]*\/(?=[^\s]+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("~/remove/me/myexec.pl /some/other/path/exec.pl\n"
"/yet/another/path/pipeit.pl | ~/remove/me/subdir/tome.pl\n"
"~/remove/me/deeply/nested/exec.pl")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)