#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)~\/remove\/me[^\s]*\/(?=[^\s]+)"
Local $sString = "~/remove/me/myexec.pl /some/other/path/exec.pl" & @CRLF & _
"/yet/another/path/pipeit.pl | ~/remove/me/subdir/tome.pl" & @CRLF & _
"~/remove/me/deeply/nested/exec.pl"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)