re = /~\/remove\/me[^\s]*\/(?=[^\s]+)/mi
str = '~/remove/me/myexec.pl /some/other/path/exec.pl
/yet/another/path/pipeit.pl | ~/remove/me/subdir/tome.pl
~/remove/me/deeply/nested/exec.pl'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result