#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?!fruits).*$|((?<count>\d{1,})\s(?<fruit>\w{1,}))"
Local $sString = "fruits 5 apples, 2 oranges, 3 bananas," & @CRLF & _
"cars 3 toyota, 4 benz, 1 trabi" & @CRLF & _
"buses 3 toyota, 4 benz, 1 trabi" & @CRLF & _
"fruits 5 apples, 2 oranges, 3 bananas,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")