re = /^(?!fruits).*$|((?<count>\d{1,})\s(?<fruit>\w{1,}))/im
str = 'fruits 5 apples, 2 oranges, 3 bananas,
cars 3 toyota, 4 benz, 1 trabi
buses 3 toyota, 4 benz, 1 trabi
fruits 5 apples, 2 oranges, 3 bananas,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end