const regex = /^(?!fruits).*$|((?<count>\d{1,})\s(?<fruit>\w{1,}))/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!fruits).*$|((?<count>\\d{1,})\\s(?<fruit>\\w{1,}))', 'igm')
const str = `fruits 5 apples, 2 oranges, 3 bananas,
cars 3 toyota, 4 benz, 1 trabi
buses 3 toyota, 4 benz, 1 trabi
fruits 5 apples, 2 oranges, 3 bananas,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}