$re = '/^(?!fruits).*$|((?<count>\d{1,})\s(?<fruit>\w{1,}))/im';
$str = 'fruits 5 apples, 2 oranges, 3 bananas,
cars 3 toyota, 4 benz, 1 trabi
buses 3 toyota, 4 benz, 1 trabi
fruits 5 apples, 2 oranges, 3 bananas,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);