import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!fruits).*$|((?<count>\\d{1,})\\s(?<fruit>\\w{1,}))";
final String string = "fruits 5 apples, 2 oranges, 3 bananas,\n"
+ "cars 3 toyota, 4 benz, 1 trabi\n"
+ "buses 3 toyota, 4 benz, 1 trabi\n"
+ "fruits 5 apples, 2 oranges, 3 bananas,";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}