# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\d{1,4}\]\[[a-zA-Z ]+\]//igm;t' <<< "asdas asdsad [1234][asd asd] asdasd"