import re
regex = re.compile(r"\[\d{1,4}\]\[[a-zA-Z ]+\]", flags=re.IGNORECASE | re.MULTILINE)
test_str = "asdas asdsad [1234][asd asd] asdasd"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)