package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\[\d{1,4}\]\[[a-zA-Z ]+\]`)
var str = `asdas asdsad [1234][asd asd] asdasd`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}