re = /\[\d{1,4}\]\[[a-zA-Z ]+\]/im
str = 'asdas asdsad [1234][asd asd] asdasd'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result