$re = '/\[\d{1,4}\]\[[a-zA-Z ]+\]/im';
$str = 'asdas asdsad [1234][asd asd] asdasd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;