# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a href=".*?)&(?:amp;)?rs[^"]*/\1/;t' <<< "<td><a href=\"https://mywebsite.com/book-234-god-is-one&rs=T&pi=DLaLVKLiMIagugSr9YFo&fed=0CBUQ9QEwAA&sdg=AFQjCNHwYLPqh3dXrKGaRucO6diyAt-hjQ\"><img src=\"image.jpg\"></a></td>"