#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<a href=".*?)&(?:amp;)?rs[^"]*"
Local $sString = "<td><a href="https://mywebsite.com/book-234-god-is-one&rs=T&pi=DLaLVKLiMIagugSr9YFo&fed=0CBUQ9QEwAA&sdg=AFQjCNHwYLPqh3dXrKGaRucO6diyAt-hjQ"><img src="image.jpg"></a></td>"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)