const regex = /(<a href=".*?)&(?:amp;)?rs[^"]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a href=".*?)&(?:amp;)?rs[^"]*', '')
const str = `<td><a href="https://mywebsite.com/book-234-god-is-one&rs=T&pi=DLaLVKLiMIagugSr9YFo&fed=0CBUQ9QEwAA&sdg=AFQjCNHwYLPqh3dXrKGaRucO6diyAt-hjQ"><img src="image.jpg"></a></td>`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);