using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a href="".*?)&(?:amp;)?rs[^""]*";
string substitution = @"\1";
string input = @"<td><a href=""https://mywebsite.com/book-234-god-is-one&rs=T&pi=DLaLVKLiMIagugSr9YFo&fed=0CBUQ9QEwAA&sdg=AFQjCNHwYLPqh3dXrKGaRucO6diyAt-hjQ""><img src=""image.jpg""></a></td>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}