# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<a href=\".*?)&(?:amp;)?rs[^\"]*"
test_str = "<td><a href=\"https://mywebsite.com/book-234-god-is-one&rs=T&pi=DLaLVKLiMIagugSr9YFo&fed=0CBUQ9QEwAA&sdg=AFQjCNHwYLPqh3dXrKGaRucO6diyAt-hjQ\"><img src=\"image.jpg\"></a></td>"
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.