use strict;
my $str = '<td><a href="https://mywebsite.com/book-234-god-is-one&rs=T&pi=DLaLVKLiMIagugSr9YFo&fed=0CBUQ9QEwAA&sdg=AFQjCNHwYLPqh3dXrKGaRucO6diyAt-hjQ"><img src="image.jpg"></a></td>';
my $regex = qr/(<a href=".*?)&(?:amp;)?rs[^"]*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";