package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a href=".*?)&(?:amp;)?rs[^"]*`)
var str = []byte(`<td><a href="https://mywebsite.com/book-234-god-is-one&rs=T&pi=DLaLVKLiMIagugSr9YFo&fed=0CBUQ9QEwAA&sdg=AFQjCNHwYLPqh3dXrKGaRucO6diyAt-hjQ"><img src="image.jpg"></a></td>`)
var substitution = []byte("\1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}