#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<TITLE>.*)\R+(?<url>(?:rtmp|http):\S*)"
Local $sString = "All text has PHP_EOL at end of its line." & @CRLF & _
"Some TITLE OF RTMP STREAM" & @CRLF & _
"rtmp://slww/best" & @CRLF & _
"Some simple text what not required to find" & @CRLF & _
"Another not required string line"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")