package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<TITLE>.*)\R+(?<url>(?:rtmp|http):\S*)`)
var str = `All text has PHP_EOL at end of its line.
Some TITLE OF RTMP STREAM
rtmp://slww/best
Some simple text what not required to find
Another not required string line`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}