import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(?<TITLE>.*)\\R+(?<url>(?:rtmp|http):\\S*)";
final String string = "All text has PHP_EOL at end of its line.\n"
+ "Some TITLE OF RTMP STREAM\n"
+ "rtmp://slww/best\n"
+ "Some simple text what not required to find\n"
+ "Another not required string line";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}