re = /(?m)^(?<TITLE>.*)\R+(?<url>(?:rtmp|http):\S*)/
str = 'All text has PHP_EOL at end of its line.
Some TITLE OF RTMP STREAM
rtmp://slww/best
Some simple text what not required to find
Another not required string line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end