using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=\'token-item\'[^>]*?>.*?(\w+).*?<\/span>";
string substitution = @"%\1%";
string input = @"<span class='token-item' style='"" + token_style + ""'>"" + token + ""</span>
<span class='token-item' style='"" + token_style + ""'>"" + token + ""</span>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}