import Foundation
let pattern = #"<span class=\'token-item\'[^>]*?>.*?(\w+).*?<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span class='token-item' style='" + token_style + "'>" + token + "</span>
<span class='token-item' style='" + token_style + "'>" + token + "</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"%\1%"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)