re = /<span class=\'token-item\'[^>]*?>.*?(\w+).*?<\/span>/
str = '<span class=\'token-item\' style=\'" + token_style + "\'>" + token + "</span>
<span class=\'token-item\' style=\'" + token_style + "\'>" + token + "</span>'
subst = '%\\1%'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result