const regex = /<span class=\'token-item\'[^>]*?>.*?(\w+).*?<\/span>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span class=\\\'token-item\\\'[^>]*?>.*?(\\w+).*?<\\\/span>', 'g')
const str = `<span class='token-item' style='" + token_style + "'>" + token + "</span>
<span class='token-item' style='" + token_style + "'>" + token + "</span>`;
const subst = `%\1%`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);