$re = '/<span class=\'token-item\'[^>]*?>.*?(\w+).*?<\/span>/';
$str = '<span class=\'token-item\' style=\'" + token_style + "\'>" + token + "</span>
<span class=\'token-item\' style=\'" + token_style + "\'>" + token + "</span>';
$subst = "%\1%";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;