import re
regex = re.compile(r"<span class=\'token-item\'[^>]*?>.*?(\w+).*?<\/span>")
test_str = ("<span class='token-item' style='\" + token_style + \"'>\" + token + \"</span>\n"
"<span class='token-item' style='\" + token_style + \"'>\" + token + \"</span>")
subst = "%\\1%"
result = regex.sub(subst, test_str)
if result:
print(result)