#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^|[^[:digit:]])[[:digit:]]{3}($|[^[:digit:]])"
Local $sString = "" & @CRLF & _
".. 551 .. 552.. 553.." & @CRLF & _
"" & @CRLF & _
"But i need to exclude from that the numbers" & @CRLF & _
"" & @CRLF & _
"55341 55312 55227"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")