$re = '/(^|[^[:digit:]])[[:digit:]]{3}($|[^[:digit:]])/';
$str = '
.. 551 .. 552.. 553..
But i need to exclude from that the numbers
55341 55312 55227';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);