import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^[:digit:]])[[:digit:]]{3}($|[^[:digit:]])";
final String string = "\n"
+ ".. 551 .. 552.. 553..\n\n"
+ "But i need to exclude from that the numbers\n\n"
+ "55341 55312 55227";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}