using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^[:digit:]])[[:digit:]]{3}($|[^[:digit:]])";
string input = @"
.. 551 .. 552.. 553..
But i need to exclude from that the numbers
55341 55312 55227";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}