package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[^[:digit:]])[[:digit:]]{3}($|[^[:digit:]])`)
var str = `
.. 551 .. 552.. 553..
But i need to exclude from that the numbers
55341 55312 55227`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}